报错如标题:

报错原因:

Linux是有文件句柄限制的,而且Linux默认一般都是1024(阿里云主机默认是65535)。在生产环境中很容易到达这个值,因此这里就会成为系统的瓶颈,对于MongoDB来说,默认的文件打开数一般是不够的。

修改:

修改1:需要重启后才能生效

vi /etc/security/limits.conf
* soft nofile 102400
* hard nofile 409600

修改2:动态修改

cat /proc/89934/limits

prlimit --pid 89934 --nofile=65535:65535

查看:

当前进程打开了多少个文件:

ll /proc/15729/fd | wc -l

# 统计进程 55944 当前打开的文件句柄数量
ls /proc/55944/fd | wc -l

netstat -tn | grep :2717 | wc -l  

 

 

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐