今天对我的服务器发起get请求时报了个错(当时没截图,随便网上找了个图,报错是一样的)

 说是因为没有设置允许跨域请求访问

解决方法如下:

先登录我的服务器,进入系统(Linux系统)

在这里添加这行代码, 允许跨域

保存后回到usr/local/nginx/sbin目录

./nginx -t查看是否有文件配置异常

 这个错误是因为conf文件不支持注释,而且每一句后面要用;结尾,我这里之前没有加;

这样说明成功了, 再去重启nginx即可 ./nginx -s reload

此处注意有坑, 要在/usr/local/nginx/sbin目录输入命令才能执行成功,否则会报下面的错

 此时再发起跨域请求就没有报错了  

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐