【问题描述】:jenkins 无法启动
【安装环境】:Centos
【是否解决】:已解决

首先 yum install 安装方式:

1:按照官方文档的操作方式:

在这里插入图片描述

2:将Jenkins按照文档添加到启动项并且启动Jenkins

在这里插入图片描述

3:启动报错:

Job for jenkins.service failed because the control process exited
with error code. See “systemctl status jenkins.service” and
“journalctl -xe” for details.

开始排查:
3.1、按照提示使用命令查看明细 :journalctl -xe
  
3.2 找到关键错误

-- Unit jenkins.service has begun starting up.
Jul 22 15:18:12 iZbp173hgzx7f46kkjhy9vZ jenkins[1779]: jenkins: failed to find a valid Java installation
Jul 22 15:18:12 iZbp173hgzx7f46kkjhy9vZ systemd[1]: jenkins.service: main process exited, code=exited, status=1/FAILURE
Jul 22 15:18:12 iZbp173hgzx7f46kkjhy9vZ systemd[1]: Failed to start Jenkins Continuous Integration Server.

发现是没有找到有效的Java环境,遂Google了一下,发现大多的解决方法无非就是这几种

1、配置Java环境,包括使用软链将jdk环境配置到/usr/bin中

2、修改/etc/init.d/jenkins配置文件,添加实际的JDK位置

!!!重点:结果都是使用systemctl start jenkins 都是无效的,依然是提示没有找到有效的JDK环境。

在Google中突然发现一篇修改端口踩坑的文章,文章中提到使用:systemctl
启动时不会使用上述的etc/init.d/jenkins配置文件。而是会使用/usr/lib/systemd/system/jenkins.service文件

4:使用vim打开该文件,查找了java相关的配置,找到了如下配置:

在这里插入图片描述

将注释打开后修改为jdk的实际安装位置。

重启Jenkins,问题完美解决。

总结:

按照官方文档上的方式安装,并且使用systemctl启动的话,使用的配置文件不是etc/init.d/jenkins,而是/usr/lib/systemd/system/jenkins.service

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐