【转载原因:确实需要切换到,该进程启动用户】

【转载原文:https://blog.csdn.net/gsls200808/article/details/86486991】

jstack命令执行报错,报错如下

Unable to open socket file: target process not responding or HotSpot VM not loaded
The -F option can be used when the target process is not responding

通过ps命令可以查看到这个进程

网上搜到一篇关于jstack命令没有配置好的文章

切换到/tmp目录

cd /tmp

里面有好几个hsperfdata开头的目录,进目录看有没有jstack执行的进程号

经过检查发现jstack后面的进程不是在root用户执行的,切换到另一个用户执行成功

后面发现ps -aux也能看出进程是谁执行的,不用这么麻烦
————————————————
版权声明:本文为CSDN博主「gsls200808」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/gsls200808/article/details/86486991

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐