配置hadoop副本数为3但是发现只有一个文件?并且报错 java.io.IOException: Got error, status message , ack with firstBadLink
·
出现这种问题的原因是其他服务器的防火墙没有关闭,需要关闭防火墙才才能将文件同样传给另外的服务器。
输入sudo systemctl stop firewalld.service 即可关闭防火墙,就可以访问到下面的页面
永久关闭sudo systemctl disable firewalld.service
然后重新上传文件试试
可以使用 -put
或moveFromLocal
hdfs dfs -put 要上传的文件 以及上传到那个位置
然后会发现副本数为3

更多推荐
所有评论(0)