RMAN备份突遇死锁?10分钟解决ORA-48132/48170错误,提高备份性能!
·
问题现象
在运行 RMAN 备份时,警报日志中出现以下错误。
ADR or AMH operation error:; err_code=48132, "dbkh_create_pseudo_run_ctx-1"=dbkh_create_pseudo_run_ctx-1
at 0xffffffff7fff5870 placed krbb.c@25071
ORA-48132: requested file lock is busy, [HM_RUN] [/db01/app/oracle/diag/rdbms/<DB_NAME>/<SID>/lck/AM_1618_3044626670.lck]
ORA-48170: unable to lock file - already in use
SVR4 Error: 11: Resource temporarily unavailable
Additional information: 8
Additional information: 2701
'ADR file lock' wait event observed during the backup.
INST_ID SID CH SEQ# EVENT STATE SECS
---------- ------- --------------------------- ------ ---------------------------- ---------- ----------
1 262 6114 SQL*Net message from client WAITING 50
1 467 rman channel=ORA_SBT_TAPE_1 898 ADR file lock WAITING 2 >>>>>>>>>>>>>>>>>>>>>>>>>
问题原因
这个现象由 Bug 10125939导致的。
Bug 10125939 - GSFBDRA: RMAN VALIDATE HANG WAITING FOR 'ADR FILE LOCK' Closed as could not reproduce
解决方法
适用版本:Oracle 11.2.0.4 及更高版本
解决方法1:
su - oracle
例如: /db01/app/<BASE>/diag/rdbms/<sid>/<SID>/lck/AM_1618_3044626670.lck
- 关闭数据库
shutdown immediate
- 移除文件lck
cd /db01/app/<BASE>/diag/rdbms/<sid>/<SID>
mv lck lck_bkp
- 开启数据库
startup
adrci>purge
解决方法2:
启用 KBR trace ,这可能会导致生成更多的 RMAN KRB记录。
如果需要在所有节点上启用 RAC的KBR trace。
alter system set event='logon trace name krb_options level 20' scope=spfile;
alter system set event='logon trace name krb_options off' scope=spfile;
更多推荐
所有评论(0)