天工造物局 使用Rockey操作系统允许rancher镜像报错iptables is not available on this host解决方法

使用Rockey操作系统允许rancher镜像报错iptables is not available on this host解决方法

参考

  1. 环境查看
# cat /etc/redhat-release 
Rocky Linux release 9.3 (Blue Onyx)
# uname -a
Linux Rocky9K8SMaster003021 5.14.0-362.18.1.el9_3.0.1.x86_64 #1 SMP PREEMPT_DYNAMIC Sun Feb 11 13:49:23 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux
  • 1.
  • 2.
  • 3.
  • 4.
  1. 故障现象
    允许Rancher镜像时docker不停重启
    查看docker日志有以下报错信息
# k3s exited with: exit status 1
# iptables is not available on this host
  • 1.
  • 2.
  1. 原因分析
    没有加载iptables内核模块
  2. 解决方法
    手动加载模块
# sudo modprobe iptable_nat 
# sudo modprobe iptable_filter
  • 1.
  • 2.

设置到配置文件

# cat /etc/modules-load.d/modules.conf 
iptable_nat
iptable_filter
  • 1.
  • 2.
  • 3.

重启

# reboot
  • 1.



原创作者: u_13045706 转载于: https://blog.51cto.com/u_13045706/11850994
Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐

  • 浏览量 305
  • 收藏 0
  • 0

所有评论(0)

查看更多评论 
已为社区贡献9条内容