进入postgresql数据库
sudo su postgres
psql

报错如下:

2024-03-20 17:21:41.745 CST [1376] 致命错误:  私钥文件"/etc/ssl/private/ssl-cert-snakeoil.key"具有由所在组或全局范围访问的权限
2024-03-20 17:21:41.745 CST [1376] 详细信息:  如果文件被数据库用户所拥有,它必须具有权限 u=rw (0600) 或者更低;如果被 root 所拥有,它必须具有权限 u=rw,g=r (0640) 或者更低。
2024-03-20 17:21:41.746 CST [1376] 日志:  数据库系统已关闭
pg_ctl: 无法启动服务器进程

 

 

解决方法:

改私钥文件"/etc/ssl/private/ssl-cert-snakeoil.key"的拥有用户

chown root /etc/ssl/private/ssl-cert-snakeoil.key

chmod 640 /etc/ssl/private/ssl-cert-snakeoil.key

然后执行启动命令

service postgresql start

 

下附常用命令
service postgresql start
service postgresql status
/var/log/postgresql
tail postgresql-12-main.log


退出
CTRL+D或者\q 

 

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐