一、yum安装elsticsearch7.x

1.导入 Elasticsearch GPG KEY:

rpm --import https://artifacts.elastic.co/GPG-KEY-elasticsearch

2.添加elasticsearch的yum repo文件

cd /etc/yum.repos.d/
vim elasticsearch.repo

打开文件后写入如下内容

[elasticsearch-7.x]
name=Elasticsearch repository for 7.x packages
baseurl=https://mirror.tuna.tsinghua.edu.cn/elasticstack/7.x/yum/
gpgcheck=1
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch
enabled=1
autorefresh=1
type=rpm-

3.安装ES

yum install elasticsearch

查看ES版本可以使用:

yum search elasticsearch --showduplicates

指定版本主要是为了后面安装ik分词,因为ik要和ES保持相同版本

yum install elasticsearch-7.17.18-1.x86_64

4.按照如下方法解决对应报错问题:

        到此安装部分完成,如果你现要去执行一定报各种错误,各种奇怪的错误:

1.org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root。
此错误大致含义就是不可以在root用户下启动ES
解决方法:

# 添加用户,我这里叫es
adduser es 
# 给用户设置密码
passwd 123456
# 切换到es用户下
su es

2.这时切换到es用户下,又会报各种权限不足,加上权限就OK了。 

#./elasticsearch-env:行88: /etc/sysconfig/elasticsearch: 权限不够
chown -R es /etc/sysconfig/elasticsearch

#bin/elasticsearch-env: 第 96 行:cd: /etc/elasticsearch: 权限不够
chown -R es /etc/elasticsearch

#Exception in thread "main" java.nio.file.AccessDeniedException: /var/lib/elasticsearch
#只要看到AccessDeniedException异常就给它权限
chown -R es /var/lib/elasticsearch

#Error opening log file '/var/log/elasticsearch/gc.log': Permission denied
#将整个elasticsearch目录权限给它
chown -R es /var/log/elasticsearch

#另外将安装路径的权限给它,这里目前还没报错,不过报错是迟早的事
chown -R es /usr/share/elasticsearch

 3.配置es.yml文件

vim /etc/elasticsearch/elasticsearch.yml

elasticsearch默认是不支持跨域的,在末尾添加如下两行支持跨域

http.cors.enabled: true 
http.cors.allow-origin: "*"

打开并修改访问ip设置,不然只有本虚拟机才能访问,别的机器无法访问

network.host: 0.0.0.0

es节点名称

cluster.name: elasticsearch
node.name: node-1

initial_master_nodes如果不开后面会报错

cluster.initial_master_nodes: ["node-1"]

 可以在未使用到此功能的时候选择先关闭geoip库的更新,如果关闭后面会报错

ingest.geoip.downloader.enabled: false

5.卸载

1. 查询rpm安装的elasticsearch
rpm -qa | grep elasticsearch
2. rpm卸载elasticsearch(elasticsearch-6.7.2-1.noarch名称 是根据上一步查询结果来)
rpm -e --nodeps elasticsearch-6.7.2-1.noarch;
3. 删除残留文件
rm -rf /etc/elasticsearch
4. 删除elasticsearch自定义文件
rm -rf /opt/software/elasticsearch

二、yum安装kibana-7.x

1.安装:kibana

指定版本主要是为了和ES保持相同版本

yum install kibana-7.17.18-1.x86_64

2.配置kibana.yml文件

cd /etc/kibana

vim kibana.yml

设置kinbana端口号:

server.port: 5601

设置允许所有IP访问:

server.host: "0.0.0.0"

设置服务器名称:

server.name: "elasticsearch"

设置ES集群地址:

elasticsearch.hosts: ["http://localhost:9200"]

 三、yum安装ik中文分词器

1.安装:ik中文分词器

打开ES安装目录的bin文件夹:

cd /usr/share/elasticsearch/bin/

指定版本主要是为了和ES保持相同版本:

./elasticsearch-plugin install https://github.com/medcl/elasticsearch-analysis-pinyin/releases/download/v7.17.18/elasticsearch-analysis-pinyin-7.17.18.zip

查询是否安装成功:

curl -XGET localhost:9200/_cat/plugins

2. 卸载:ik中文分词器

打开ik中文分词器安装目录plugins文件夹:

cd /usr/share/elasticsearch/plugins

删除:

rm -rf  analysis-pinyin

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐