参考:
端口号被占用【Error】严重: Failed to initialize end point associated with ProtocolHandler [“http-bio-8080”]

Tomcat启动报错: StandardServer.await: create[8005] 简单解决方案

原因:之前启动了Tomcat服务器,但是没有正常的关闭,造成8080端口号的进程依旧在系统后台运行着,导致Tomcat重启失败。

解决方案:首先打开cmd,然后:

  1. 查看指定端口的占用情况 netstat -aon|findstr “8080”

  2. 查看PID对应的进程 tasklist|findstr “PID”

  3. 结束该进程 taskkill /f /t /im java.exe(程序名称+exe)

同理,StandardServer.await: create[8005]是因为8005端口已经被占用了,通常是idea等编译器非正常退出导致的。

org.apache.catalina.core.StandardServer await
严重: StandardServer.await: create[8005]:
java.net.BindException: Address already in use
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:365)
at java.net.ServerSocket.bind(ServerSocket.java:319)
at java.net.ServerSocket.(ServerSocket.java:185)
at org.apache.catalina.core.StandardServer.await(StandardServer.java:373)
at org.apache.catalina.startup.Catalina.await(Catalina.java:662)
at org.apache.catalina.startup.Catalina.start(Catalina.java:614)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
org.apache.coyote.http11.Http11Protocol pause

解决方法:打开cmd

  1. 找到占用端口8005的进程号 netstat -ano | findstr “8005”
  2. 查看进程号对应的进程名 tasklist | findstr “进程号”
  3. 结束该进程 taskkill /f /t /im javaw.exe
Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐