elasticsearch分片lock锁无法分配

报错内容如下所示

出现这个问题的原因是原有分片未正常关闭或者清理,所以当分片要重新分配回出问题节点时就会没办法获取分片锁,这不会导致数据丢失,只需要重新出发一下分配分片的操作即可

failed to obtain in-memory shard lock

在这里插入图片描述

curl -XPOST "http://192.168.10.10:9200/_cluster/reroute?retry_failed"
或者
curl -XPOST "http://192.168.10.10:9200/_cluster/reroute?retry_failed=true"

在这里插入图片描述

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐