上一篇搭建了nacos集群,注册服务的时候发生了报错

客户端配置如下

spring:
  application:
    name: order-nacos-service
  profiles:
    active: dev
  cloud:
    nacos: # nacos配置
      discovery:
        server-addr: www.xxxxxxxxxx.com:7000
      config:
        server-addr: www.xxxxxxxxxx.com:7000
        file-extension: yaml
        prefix: nacos-order

控制台报错,server is DOWN now, please try again later!

此处报错是因为我复制的三分程序包之前使用过单机环境,不是新解压出来的;产生了data数据目录,里面的一些内容与当前的集群不兼容导致的;新解压出来的nacos是没有data目录的;

使用过的
在这里插入图片描述

新解压的

解决方法
1.删除data下的protocol目录
2.重新解压一份新的程序(推荐)

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐