前言,不想看废话的,直接去下面看1:前一天晚上搞了一晚上,每次启动正常不报错,但就是ps -ef | grep nacos|grep -v grep|wc -l的结果为0,我不断的找自己配置上的问题都没发现,最后关机睡觉了,结果第二天早晨,启动了第一台发现ps -ef | grep nacos|grep -v grep|wc -l 的结果是1了,我兴奋的启动第二台,发现ps -ef | grep nacos|grep -v grep|wc -l的结果还是为1,这一下就排除了我配置上的错误,我开始怀疑是其他问题了,于是我便看了下启动日志

****1.去看看启动日志,看看是报错还是什么其他原因(我的原因是虚拟机分配的内存不够了,由于当时忘记截图,我把报错的部分复制了下来)
位置vi %home/nacos/conf/nacos/logs/start.out

Java HotSpot(TM) 64-Bit Server VM warning: INFO: os::commit_memory(0x0000000794500000, 576716800, 0) failed; error='Cannot allocate memory' (errno=12)

2.关机,把内存调大(我个人调整为了4G,可根据自己的需求调整)
在这里插入图片描述3.开机在启动集群
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
o(╥﹏╥)o,终于,我吐了

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐