hive 开启了hiveServer2服务,连接了一段时间就拒绝连接,hive日志报错如下:
Exception in thread "org.apache.hadoop.hive.common.JvmPauseMonitor$Monitor@56b9d43f" java.lang.OutOfMemoryError: Java heap space
Exception in thread "TriggerValidator" java.lang.OutOfMemoryError: Java heap space
java.io.IOException: DestHost:destPort 10.38.248.149:9000 , LocalHost:localPort vm10-38-248-149.ksc.com/127.0.0.1:0. Failed on local exception: java.io.IOException: Couldn't set up IO streams: java.lang.OutOfMemoryError: Java heap space

问题原因:

客户端用户连接hiveServer2服务后没有关闭,到底资源一直占用浪费

解决方式:

客户端:

增加 conn.dispose(),每次代码连接完成关闭资源

服务端:

1.重启hiveServer2服务,直接将所有连接都断了嘛

2.修复hive-site.xml文件,增加内存大小

<property>
	<name>yarn.scheduler.maximum-allocation-mb</name>
	<value>2048</value>
</property>

<property>
  	<name>yarn.scheduler.minimum-allocation-mb</name>
  	<value>2048</value>
</property>
<property>
	<name>yarn.nodemanager.vmem-pmem-ratio</name>
	<value>2.1</value>
</property>
<property>
	<name>mapred.child.java.opts</name>
	<value>-Xmx1024m</value>
</property>

 

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐