博主在配置ftp服务器的时候
自己生成的CA,然后认证自己的私钥文件
一切配置都是没有问题的,然后重新启动服务器
service vsftpd restart    出现以下错误
为 vsftpd 启动 vsftpd:500 OOPS: SSL: cannot load RSA certificate

产生原因
rsa_key_file = /etc/vsftpd/ssl/ssl_key.pem

此处的文件应该是通过CA认证之后的公钥文件ssl_key.crt,而不是自己生成的私钥文件
openssl ca -in  ssl_key.pem -out ssl_key.crt

转载于:https://www.cnblogs.com/huwentao/p/6999171.html

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐