报错fielddata is disabled on text fields by default. set fielddata=true on [aaaa]

1、开启fielddata,

put  http://127.0.0.1:9200/indexName/_mapping/yourtype
{
  "properties": {
    "aaaa": { 
      "type":     "text",
      "fielddata": true
    }
  }
}

yourtype 是创建索引时,mappings内的key,例如下面的item

mappings: {  
    item: {  
        properties: {  
            description: {  
                type: string  
            }  
            name: {  
                type: string  
            }  
        }  
    }  
} 

aaaa就是text域,需要设置fielddata=true的字段

2、试试把field 的 aaaa, 改为 aaaa.keyword

https://www.elastic.co/guide/en/elasticsearch/reference/current/_executing_aggregations.html
在Aggregations 聚合查询(=sql: group) 时,”field”: “state.keyword” 改为”field”: “state”也会报错,所以试试

Logo

北京人形旗下天工造物具身智能开源社区,聚焦具身天工与慧思开物两大平台

更多推荐